Don’t understand Yarn check warning

When I run yarn check I got this warning:

 warning "\u001b[2mchokidar#\u001b[22mfsevents#[email protected]^0.6.29"
 could be deduped from "0.6.32" to "[email protected]"

Would someone please help me understand this?

  • I don’t know what does the word deduped mean.
  • Why there are so many rubbish characters in the warning message?
  • What should I do to solve this warning?

Many thanks!

It looks like that your yarn.lock file contains a duplicated entry for the package node-pre-gyp at the version 0.6.32.

You can do the following steps:

  1. Delete the yarn.lock file.
  2. Reinstall the packages to generate a new yarn.lock yarn install.
  3. Run again the yarn check command.


The answers/resolutions are collected from stackoverflow, are licensed under cc by-sa 2.5 , cc by-sa 3.0 and cc by-sa 4.0 .
Read More:   (node:9374) Warning: To load an ES module, set "type": "module"

Similar Posts